با ثبت نام در سایت از مزایای اعضا بهره مند شوید!

عدم دسترسی به لینوکس پس ازنصب مجددویندوز

+1 امتیاز
83 بازدید
سوال شده آبان 10, 1394 در دستورات لینوکس توسط son89 (32 امتیاز)
برچسب گذاری دوباره آبان 12, 1394 توسط son89
با سلام بنده در کنار ویندوز اقدام به نصب لینوکس کردم . بعد از مدتی ویندوز رو پاک و دوباره نصب کردم اما پس از نصب ویندوز دیگر دسترسی به لینوکسم ندارم(گراپ نمایش داده نمیشه) . تنظیمات بایوس روهم برای مدیریت بوت ها چک کردم  تاثیری نداشت .

1 پاسخ

0 امتیاز
پاسخ داده شده آبان 10, 1394 توسط hasan1 (1,474 امتیاز)

سلام دوست عزیز

اوبونتو را از روی دیسک زنده لود کن.
توی ترمینال دستورات زیر را یکی یکی اجرا کن.

sudo mount /dev/sda8 /mnt

sudo grub-install --root-directory=/mnt /dev/sda

sudo reboot -f

 به جای عدد 8 در دستور اول پارتیشنی که اوبونتو روی اون نصب است را وارد کن مثلا من درایو 8 درایوی است که ابونتو رو نصب

کردم  . (می تونی از دستور زیر

sudo fdisk -l
کمک بگیری ).

بعد موقعی که وارد ابونتو شدی یه بار دستور زیر رو وارد کن

sudo update-grub

با تشکر 
دارای دیدگاه آبان 10, 1394 توسط son89 (32 امتیاز)
سلام دستوری که گفتین رو میزنم با خطای زیر روبرو میشم  

can not find /dev/sda5/mnt or /etc/mtab
دارای دیدگاه آبان 10, 1394 توسط hasan1 (1,474 امتیاز)

سلام شرمونده

دستور وارد کن

sudo mount  /dev/sda۵   /mnt

sudo grub-install   --root-directory=/mnt   /dev/sda

ببین درست میشه

دارای دیدگاه آبان 12, 1394 توسط son89 (32 امتیاز)

ممنون روشی که گفتین درسته فقط  قسمت 

sudo grub-install   --root-directory=/mnt   /dev/sda

باید باشه

sudo grub-install –boot-directory=/mnt/boot /dev/sda

لینک اموزش کاملش رو میزازم واسه دوستان 

http://www.howtogeek.com/114884/how-to-repair-grub2-when-ubuntu-wont-boot/

 

سرور مجازی لینوکس

2,160 سوال

3,311 پاسخ

3,437 دیدگاه

9,388 کاربر

...